Chyby Meltdown a Spectre na procesorech a jak je řešíme

Publikováno: 05.01.2018

Procesory obsahují dvě bezpečnostní chyby s názvy Meltdown a Spectre, které potenciálně umožňují útočným programům dostat se k datům, která jsou v počítači aktuálně zpracovávána. Meltdown je schopen přerušit bariéru, která je mezi uživatelskými aplikacemi a operačním systémem, a získat tak přístup do paměti v rámci stejného cloudu. Spectre umožňuje aplikacím dostat se do různých míst paměti. Chyba se týká x86-64 procesorů, tedy procesorů používaných ve všech cloudech po celém světě.

Náš bezpečnostní tým a tým infrastruktury na nápravách usilovně pracují. Po vydání updatů pro operační systémy, budeme úpravy nasazovat na všechny managed a interní servery. V médiích se objevují tvrzení o snižování výkonu až o desítky procent, což není aktuáně potvrzeno a bude to záležet na konkrétních případech. U serverů, kde by mohly nastat provozní komplikace v důsledku nedostatku výkonu, budeme klientům doporučovat preventivní navýšení výkonu.

V případě dotazů nás kontaktujte emailem na podpora@vshosting.cz

Doporučení:

Webové aplikace udržujte vždy kompatibilní s aktuálními verzemi PHP a dalších komponent, aby bylo možné udržovat aktuální verzi operačního systému, která je podporovaná komunitou či výrobcem včetně bezpečnostních aktualizací. Dlouhodobě upozorňujeme uživatele na zastaralost PHP verzí až do verze 5.3 včetně (od jara tohoto roku od verze 5.4 dále), které přináší komplikace z pohledu nutnosti provozování zastaralých verzí souvisejících knihoven a operačních systémů z důvodu kompatibility. Nové verze PHP (7+) navíc disponují výrazně větším výkonem. Nejde samozřejmě jen o verzi PHP, nicméně staré verze PHP nejčastěji tvoří blocker, a vytváří tak zbytečné bezpečnostní riziko.

Leave a Reply

Your email address will not be published. Required fields are marked *